平淡空间

 找回密码
 立即注册
查看: 201|回复: 0

易语言中多线程超稳定用法

[复制链接]

9

主题

13

帖子

70

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
70
发表于 2022-6-26 00:01:07 | 显示全部楼层 |阅读模式
大家好,第一期易语言电子期刊与大家见面了。在此开设了一个“易语言编程技巧”的栏目,将一些在易语言中使用的技巧介绍给大家,希望大家喜欢。不知大家试了没有,在易语言自带多线程的使用中,会发现一些不稳定的现象,如:程序运行不稳定、退出程序时报错、有死机现象、多线程中不能直接销毁组件等。例如运行以下代码,程序会自动退出。

.子程序 _按钮1_被单击
启动线程 (&多线程子程序, )

.子程序 多线程子程序
按钮1.销毁 ()  ' 直接用就是不行哦!

现在,大家可以改变一下调用多线程的方式,用标签的反馈事件执行多线程子程序,
绝大部分不稳定问题都可以解决了。
具体执行代码要写在标签反馈事件中,多线程中再用标签的“调用反馈事件”去调用。易语言对这个标签组件的反馈事件做过特殊处理。
上述代码可写为以下,运行就可以通过了:

.子程序 _按钮1_被单击
启动线程 (&多线程子程序, )

.子程序 多线程子程序
标签1.调用反馈事件 (0, 0, 假)

.子程序 _标签1_反馈事件, 整数型
.参数 参数一, 整数型
.参数 参数二, 整数型
按钮1.销毁 ()

注意:以下调用是错误的!
启动线程 (&_标签1_反馈事件, )

.子程序 多线程子程序
_标签1_反馈事件()


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|平淡空间

GMT+8, 2022-9-26 05:21 , Processed in 0.322749 second(s), 19 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表